FCI-Helwan blog

Just another FCI-H weblog

Running Netbeans on XGL

If you tried to use Netbeans on XGL before, you probably know that you can’t do it. It shows like an empty window. The solution being around is that you use a nested X server and so on. Other solutions include recompiling the JRE.

Well, I ran into a simple solution. You can add this to /etc/environment, and viola, it is working:
AWT_TOOLKIT=”MToolkit”

For command line guys:
sudo echo ‘AWT_TOOLKIT=”MToolkit”‘ >> /etc/environment

Have fun 😉

http://ubuntuforums.org/showpost.php?p=1687890&postcount=4

Advertisements

February 25, 2007 - Posted by | Linux

2 Comments »

  1. Hi,

    I’m the Community Docs Manager for NetBeans. I’ve read your blog entry, and I think this would be great content for our Community Docs wiki page. Would you be interested in contributing this in the category “Tips and Tricks”?

    I look forward to your reply.

    James Branam
    NetBeans Community Docs manager
    james.branam@sun.com

    Comment by James Branam | February 26, 2007 | Reply

  2. http://wiki.netbeans.org/wiki/view/CommunityDocs

    Comment by Mohammad Nabil | March 7, 2007 | Reply


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: